<?xml version="1.0" encoding="UTF-8"?>
<rss version="2.0"><channel>
  <title>Security alerts | walterstein.eu</title>
  <link>https://walterstein.eu/en/security-alerts/</link>
  <description>In-depth articles on current vulnerabilities: why they are dangerous, who is affected and how to fix them.</description>
  <language>en</language>
  <item>
    <title>Critical Argo CD Jsonnet flaw lets users with view access read tokens and keys from repo-server</title>
    <link>https://walterstein.eu/en/security-alerts/argo-cd-cve-2026-113672</link>
    <guid>https://walterstein.eu/en/security-alerts/argo-cd-cve-2026-113672</guid>
    <pubDate>Wed, 28 Oct 2026 16:15:51 GMT</pubDate>
    <description>Argo CD, a tool that deploys applications to Kubernetes, has a critical flaw rated CVSS 9.9. Anyone who can commit a Jsonnet file to a repository, or merely view an existing Directory-type application, can pull tokens, keys and Git credentials from the repo-server. A fix is available.</description>
  </item>
  <item>
    <title>Critical Snort 3 flaws put Cisco FTD firewalls, Meraki MX and IOS XE routers at risk</title>
    <link>https://walterstein.eu/en/security-alerts/snort-3-cve-2026-20043</link>
    <guid>https://walterstein.eu/en/security-alerts/snort-3-cve-2026-20043</guid>
    <pubDate>Wed, 28 Oct 2026 16:09:56 GMT</pubDate>
    <description>On October 21, 2026, Cisco fixed a batch of flaws in the Snort 3 inspection engine used by its firewalls and security gateways. The most serious score 9.0 on CVSS. No exploitation is known yet, but there is no workaround, so updating is the only real protection.</description>
  </item>
  <item>
    <title>Exploited Apple CoreGraphics flaw lets a malicious file run code on iPhones, iPads and Macs</title>
    <link>https://walterstein.eu/en/security-alerts/ios-ipados-macos-cve-2026-86950</link>
    <guid>https://walterstein.eu/en/security-alerts/ios-ipados-macos-cve-2026-86950</guid>
    <pubDate>Wed, 28 Oct 2026 13:29:08 GMT</pubDate>
    <description>Apple has fixed CVE-2026-86950, a CoreGraphics flaw likely already used in a targeted attack. A booby-trapped file can run an attacker’s code on an iPhone, iPad or Mac. Update to iOS and iPadOS 26.7.1 or 18.7.11, macOS Tahoe 26.7.1 or macOS Sequoia 15.8.1.</description>
  </item>
  <item>
    <title>Critical GitLab flaw may let attackers run code on the server without logging in</title>
    <link>https://walterstein.eu/en/security-alerts/gitlab-cve-2026-110264</link>
    <guid>https://walterstein.eu/en/security-alerts/gitlab-cve-2026-110264</guid>
    <pubDate>Wed, 28 Oct 2026 13:19:58 GMT</pubDate>
    <description>On October 21, 2026, GitLab fixed a critical vulnerability, CVE-2026-110264, rated CVSS 10.0. Under certain conditions, an attacker without an account could run code on a GitLab server over the network. Self-managed installs from version 7.0 are affected, so update now.</description>
  </item>
  <item>
    <title>GitLab CE and EE: exploited flaw lets attackers read server files without logging in</title>
    <link>https://walterstein.eu/en/security-alerts/gitlab-cve-2026-85706</link>
    <guid>https://walterstein.eu/en/security-alerts/gitlab-cve-2026-85706</guid>
    <pubDate>Wed, 28 Oct 2026 13:17:54 GMT</pubDate>
    <description>A critical flaw in self-hosted GitLab, CVE-2026-85706, can under certain conditions let anyone read files from the server without logging in. Those files may include passwords and keys. Since September 11, 2026, it has been officially listed as exploited. Update now and review your logs.</description>
  </item>
  <item>
    <title>MikroTik RouterOS: attackers take over routers with exposed SSH, update now</title>
    <link>https://walterstein.eu/en/security-alerts/routeros-cve-2026-86060</link>
    <guid>https://walterstein.eu/en/security-alerts/routeros-cve-2026-86060</guid>
    <pubDate>Wed, 28 Oct 2026 13:14:44 GMT</pubDate>
    <description>Flaws in the SSH login of MikroTik RouterOS let an attacker take over a router without a password if SSH is reachable from the internet. Attacks have been under way since at least September 2, 2026. Update to 7.24.3, 7.23.6 or 6.49.21 and check the device for unknown accounts.</description>
  </item>
  <item>
    <title>Adobe Commerce and Magento: exploited PolyShell flaw lets attackers plant malicious code in stores</title>
    <link>https://walterstein.eu/en/security-alerts/adobe-commerce-magento-cve-2026-48356</link>
    <guid>https://walterstein.eu/en/security-alerts/adobe-commerce-magento-cve-2026-48356</guid>
    <pubDate>Wed, 28 Oct 2026 13:11:56 GMT</pubDate>
    <description>Attackers are mass-exploiting the PolyShell flaw (CVE-2026-48356) in Adobe Commerce and Magento. They upload a malicious file, take over the store and inject code that runs in shoppers’ browsers. Install update APSB26-73 and check whether your store has already been compromised.</description>
  </item>
  <item>
    <title>Critical Collabora Online flaw for Nextcloud lets attackers backdoor servers</title>
    <link>https://walterstein.eu/en/security-alerts/collabora-online-cve-2026-110447</link>
    <guid>https://walterstein.eu/en/security-alerts/collabora-online-cve-2026-110447</guid>
    <pubDate>Wed, 28 Oct 2026 13:09:12 GMT</pubDate>
    <description>The Collabora Online Built-in CODE Server app for Nextcloud has a critical flaw that attackers are already exploiting. Without logging in, they can run commands on the server and plant a web shell. Version 26.4.303 fixes it, so update as soon as you can.</description>
  </item>
  <item>
    <title>Actively exploited Brotli flaw puts Node.js, .NET, PHP on Windows and other software at risk</title>
    <link>https://walterstein.eu/en/security-alerts/brotli-cve-2026-111497</link>
    <guid>https://walterstein.eu/en/security-alerts/brotli-cve-2026-111497</guid>
    <pubDate>Wed, 28 Oct 2026 13:01:34 GMT</pubDate>
    <description>A critical flaw, CVE-2026-111497, in Google’s Brotli library lets an unauthenticated attacker corrupt memory over the network and potentially run code. It affects Node.js, .NET, Python, PHP for Windows and other software. Attackers are already exploiting it, so update as soon as you can.</description>
  </item>
  <item>
    <title>PHP2Shell: two critical PHP flaws let attackers run code on servers without logging in</title>
    <link>https://walterstein.eu/en/security-alerts/php-cve-2026-109618</link>
    <guid>https://walterstein.eu/en/security-alerts/php-cve-2026-109618</guid>
    <pubDate>Wed, 28 Oct 2026 06:00:00 GMT</pubDate>
    <description>Two flaws in the PHP core can let an attacker on the internet run their own code on a server without logging in. CISA says they are already being exploited. The only reliable protection is updating PHP to 8.2.35, 8.3.36, 8.4.27 or 8.5.12 and restarting every PHP process.</description>
  </item>
</channel></rss>
